Resolved
Flow EVM has all the latest data.
Identified
Flow EVM data is missing some of the latest data.
·