Contact our Team
Subscribe to updates
Contact our Team
Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Token Terminal API is down
Resolved
·
Full outage
Mon, Mar 2, 2026, 01:13 PM
(
1
week ago)
·
View all updates
Affected components
Mar 2, 2026, 12:55 PM
01:13 PM
Explorer
1 affected component
Updates
Resolved
This incident has been resolved.
Mon, Mar 2, 2026, 01:13 PM
Investigating
Our team is investigating
Mon, Mar 2, 2026, 12:55 PM
(
18
minutes earlier)
Token Terminal API is down - Token Terminal Status